Search found 52 matches

by nightz13
Fri Sep 21, 2007 2:33 pm
Forum: C++ Development
Topic: wxExecute
Replies: 3
Views: 1271

Try to redirect the I/O of the process launched by wxExecute. The help says: If the child process IO is redirected, under Windows the process window is not shown by default I use code of the form p_exiftime = new wxProcess(wxPROCESS_REDIRECT); if ( !::wxExecute(cmd,wxEXEC_ASYNC,p_exiftime) ) // exe...
by nightz13
Thu Sep 20, 2007 7:53 pm
Forum: C++ Development
Topic: wxExecute
Replies: 3
Views: 1271

wxExecute

Hello, I'd like to use wxExecute to launch another app from my app. It must be launched minimized or minimized shortly after being launched. I've done this using wxShell without issue but I'd like to have the process control features of wxExecute. Eventually I need to kill the process. I've been sea...
by nightz13
Tue Sep 18, 2007 9:14 pm
Forum: C++ Development
Topic: DDE Question
Replies: 1
Views: 566

Got it....

In addition to the DDEService and DDETopic names, MPManager provides me a DDEItem (DDEItem=DDEStatus). This is what I was not properly using.

I code:
bla_bla_bla->Request("DDEStatus");
and I get the ASCII response I've been looking for.

-Rocko
by nightz13
Tue Sep 18, 2007 8:58 pm
Forum: C++ Development
Topic: DDE Question
Replies: 1
Views: 566

DDE Question

After being pulled into other issues...I'm back to my DDE Client application...and I have a new issue. My Server application (MPManager)states the following: 2.4 Sending Messages to MPManager Once the Client has successfully connected to the MPManager DDE Server, it can issue commands to MPManager u...
by nightz13
Tue Jul 31, 2007 3:14 am
Forum: wxDev-C++
Topic: Library Mod?
Replies: 2
Views: 707

Today, as a first step, I changed the value of DDE_TIMOUT to 60000 and recompiled the library. I guess this was a good thing to do anyway since the source for wxWidgets has been updated since the last release of wxDev-Cpp. I copied over the updated files and compiled my application code. It worked g...
by nightz13
Mon Jul 30, 2007 2:14 pm
Forum: wxDev-C++
Topic: Library Mod?
Replies: 2
Views: 707

Library Mod?

Hello, What I'm trying to do is a little new to me so hopefully I'll explain my issue well enough for someone to be able to help me. I've been using wxDev-Cpp for almost two years with great success. I've just ran into a little roadblock recently. I'm using wxDDEClient in my code but for this questi...
by nightz13
Sun Jul 29, 2007 4:09 am
Forum: General Development
Topic: wxDDEConnection
Replies: 2
Views: 898

xicu,

what #define did you change?
In the .H or the .CPP file? I can only find a DDE.H file.

-Rocko
by nightz13
Fri Jul 27, 2007 4:06 pm
Forum: C++ Development
Topic: DDE Question
Replies: 0
Views: 349

DDE Question

Hello, Not much info here on DDE links. Hopefully someone can assist. Here's my code: wxDDEClient MPQClient; wxConnectionBase *MPQConnection = MPQClient.MakeConnection(wxEmptyString, "MPManager", "DDELink"); MPQConnection->Execute("CommSelect|3"); MPQConnection->Execute("FindProgrammers"); I'm writt...
by nightz13
Fri Dec 22, 2006 8:41 pm
Forum: C++ Development
Topic: fopen issues
Replies: 12
Views: 2686

](*,) Now I know what's meant by "You can't fix stupid" ](*,) So when you have two functions, one to load settings from a file, and one to actually use those settings, it helps to call them in the proper order. It's working...and now I need to go spend more time developing my debugging skills. Thank...
by nightz13
Fri Dec 22, 2006 8:00 pm
Forum: C++ Development
Topic: fopen issues
Replies: 12
Views: 2686

The plot thickens.... I've been using wxWidgets for about a year and half now....off and on so, I still have much to learn. This thread is my first exposure to wxLogMessage. I've been meaning to learn how to use the debugging mode and log features but, haven't made it a priority. wxLogMessage helped...
by nightz13
Fri Dec 22, 2006 2:37 pm
Forum: C++ Development
Topic: fopen issues
Replies: 12
Views: 2686

Interesting....here is the code that actually worked. wxString fileName = "fast_models.txt"; wxTextFile file; wxString str; fileName.Format("%s%s",settings.modelPath.mb_str(),settings.modelFile.mb_str()); wxFileName modelsFile(fileName); if (modelsFile.FileExists()) { file.Open(fileName); } Notice t...
by nightz13
Thu Dec 21, 2006 8:51 pm
Forum: C++ Development
Topic: fopen issues
Replies: 12
Views: 2686

Doh!

ok it worked once...I hate it when that happens....
Still trying to solve.....

-Rocko
by nightz13
Thu Dec 21, 2006 8:46 pm
Forum: C++ Development
Topic: fopen issues
Replies: 12
Views: 2686

I gave up on fopen... My solution: wxString fileName; wxTextFile file; wxString str; fileName.Format("%s%s",settings.modelPath.mb_str(),settings.modelFile.mb_str()); wxFileName modelsFile(fileName); if (modelsFile.FileExists()) { file.Open(fileName); } if (file.IsOpened()) { / bla bla bla } else { /...
by nightz13
Thu Dec 21, 2006 8:31 pm
Forum: C++ Development
Topic: Partial Repainting
Replies: 3
Views: 855

can also try wxYield();
by nightz13
Thu Dec 21, 2006 3:51 pm
Forum: C++ Development
Topic: fopen issues
Replies: 12
Views: 2686

Hi, The surprising thing isn't that using settings.modelFile.c_str()) in strcat fails, it's that strcpy(modelsFilename, settings.modelPath.c_str()) works. Exactly! I think that's what bothered me most is why I couldn't get it to work with both. I think it's because in the first snippet strcat(model...