Search found 145 matches

by Mick P.
Thu Apr 15, 2021 4:56 am
Forum: Compiler / Linking / IDE Related
Topic: MSW: 3.1.2 + CMake3.19 install link errors (VS2015) (Edited: actually FindwxWidgets.cmake mostly)
Replies: 14
Views: 3880

Re: MSW: 3.1.2 + CMake3.19 install link errors (VS2015) (Edited: actually FindwxWidgets.cmake mostly)

I'm not trying to debate that, but you give several different solutions in different settings, which is the problem CMake is designed to address, by reducing it to one system. For publishing open-source software we don't want to maintain complicated recipes for every environment (ideally we don't wa...
by Mick P.
Wed Apr 14, 2021 2:25 am
Forum: Compiler / Linking / IDE Related
Topic: MSW: 3.1.2 + CMake3.19 install link errors (VS2015) (Edited: actually FindwxWidgets.cmake mostly)
Replies: 14
Views: 3880

Re: MSW: 3.1.2 + CMake3.19 install link errors (VS2015)

Why do you want to use CMake?
It's portable across platforms like wxWidgets.

For the record, here's a ticket: https://trac.wxwidgets.org/ticket/19144
by Mick P.
Tue Apr 13, 2021 9:27 am
Forum: Compiler / Linking / IDE Related
Topic: MSW: 3.1.2 + CMake3.19 install link errors (VS2015) (Edited: actually FindwxWidgets.cmake mostly)
Replies: 14
Views: 3880

Re: MSW: 3.1.2 + CMake3.19 install link errors (VS2015)

AFAIK, CMake's FindwxWidgets module generally relies on the environment variable WXWIN, which the programmer is supposed do set correctly, regardless of the build tool used, see wxWidgets docs. Otherwise, you need to set wxWidgets_ROOT_DIR and wxWidgets_LIB_DIR CMake variables to point to the corre...
by Mick P.
Tue Apr 13, 2021 9:21 am
Forum: Compiler / Linking / IDE Related
Topic: MSW: 3.1.2 + CMake3.19 install link errors (VS2015) (Edited: actually FindwxWidgets.cmake mostly)
Replies: 14
Views: 3880

Re: MSW: 3.1.2 + CMake3.19 install link errors (VS2015)

So I'm still going to dig into the odd dates around these seemingly incompatible versions, but for the record after adding my version to the top of the list, it was found, and to build/install wxWidgets itself I manually edited the CMAKE_INSTALL_PREFIX in CMake-GUI and deleted its cache (maybe it wa...
by Mick P.
Tue Apr 13, 2021 7:05 am
Forum: Compiler / Linking / IDE Related
Topic: MSW: 3.1.2 + CMake3.19 install link errors (VS2015) (Edited: actually FindwxWidgets.cmake mostly)
Replies: 14
Views: 3880

Re: MSW: 3.1.2 + CMake3.19 install link errors (VS2015)

Good point, it looks pretty fragile. Of those environment variables I have "WXWIDGETS=C:\wxWidgets-3.1.2" but that's not even in its list #-o (Assuming these are environment variables... I think so... and not CMake internal things... maybe they're both.) Edited: Something tells me it would combine t...
by Mick P.
Tue Apr 13, 2021 6:52 am
Forum: Compiler / Linking / IDE Related
Topic: MSW: 3.1.2 + CMake3.19 install link errors (VS2015) (Edited: actually FindwxWidgets.cmake mostly)
Replies: 14
Views: 3880

Re: MSW: 3.1.2 + CMake3.19 install link errors (VS2015)

Maybe but that's not a correct path anyway... I think it's probably a default path. For the heck of it I looked in the script that comes with CMake and noticed the following: #------------------------------------------------------------------- # WIN32: Start actual work. #---------------------------...
by Mick P.
Tue Apr 13, 2021 2:07 am
Forum: Compiler / Linking / IDE Related
Topic: MSW: 3.1.2 + CMake3.19 install link errors (VS2015) (Edited: actually FindwxWidgets.cmake mostly)
Replies: 14
Views: 3880

MSW: 3.1.2 + CMake3.19 install link errors (VS2015) (Edited: actually FindwxWidgets.cmake mostly)

Update: I feel like I should rename this topic to emphasize "find_package/FindwxWidgets.cmake" since the link errors mostly shook out. Ticket about the find_package script: https://trac.wxwidgets.org/ticket/19144 I think I upgraded CMake a while ago and now I'm in hell trying to build static wxWidg...
by Mick P.
Sun Dec 27, 2020 11:57 am
Forum: Platform Related Issues
Topic: wxMSW: Menus corrupted systemwide, even after app quits, GDI object count looks normal?
Replies: 11
Views: 1268

Re: wxMSW: Menus corrupted systemwide, even after app quits, GDI object count looks normal?

SD? Well the behavior I described originally was in fact different. It's what brought my attention back to the problem. I really think it was a bug in Windows that got patched out the next day. If not it was a system wide phenomenon that depended on outside factors. (But because it happened across r...
by Mick P.
Thu Dec 24, 2020 9:17 am
Forum: C++ Development
Topic: Cleanly show/hide tool-tip? (not set tool tip)
Replies: 11
Views: 716

Re: Cleanly show/hide tool-tip? (not set tool tip)

I definitely notice it. I won't submit it to the tracker until I've had time to investigate the options so I can provide a solution to the problem. I started out by wanting to match the toolbar behavior. I do think even if a tooltip is cleared if it's on screen it should fade out the same way it nor...
by Mick P.
Thu Dec 24, 2020 9:10 am
Forum: Platform Related Issues
Topic: wxMSW: Menus corrupted systemwide, even after app quits, GDI object count looks normal?
Replies: 11
Views: 1268

Re: wxMSW: Menus corrupted systemwide, even after app quits, GDI object count looks normal?

ONEEYEMAN wrote:
Mon Dec 21, 2020 5:06 pm
Hi,
Can you create a minimal, compilable sample to see the problem and post it here?

Thank you
You know, sometimes you seem like a troll or a bot ONEEYEMAN :^o EDITED: Also, for the record, I solved the problem in my prior reply/post, I probably should've made that more clear #-o
by Mick P.
Mon Dec 21, 2020 2:13 pm
Forum: Platform Related Issues
Topic: wxMSW: Menus corrupted systemwide, even after app quits, GDI object count looks normal?
Replies: 11
Views: 1268

Re: wxMSW: Menus corrupted systemwide, even after app quits, GDI object count looks normal?

EDITED/FOREWORD: This is a solution to the problem. I failed to open my salvo by making that obvious, sorry #-o Okay, the really weird behavior went away yesterday morning. That same morning Windows 10 started with the new Windows Update style blue screen (with infantile cartoons and gamer like ico...
by Mick P.
Sun Dec 20, 2020 1:01 pm
Forum: C++ Development
Topic: Cleanly show/hide tool-tip? (not set tool tip)
Replies: 11
Views: 716

Re: Cleanly show/hide tool-tip? (not set tool tip)

Well I guess the problem is I can't find a (professional presentation) way to "dismiss it". I may report how it fails to fade out as a bug. (I'm usually met with resistance because I don't do it the "wxWidgets way" instead of kindly making wxWidgets more applicable to different scenarios.) I'm proba...
by Mick P.
Sat Dec 19, 2020 2:32 am
Forum: C++ Development
Topic: Cleanly show/hide tool-tip? (not set tool tip)
Replies: 11
Views: 716

Re: Cleanly show/hide tool-tip? (not set tool tip)

doublemax wrote:
Fri Dec 18, 2020 9:12 pm
I think OP has a single wxWindow with custom drawn content and wants different tooltips for different areas of that window.
Correct.
by Mick P.
Fri Dec 18, 2020 3:23 pm
Forum: C++ Development
Topic: Cleanly show/hide tool-tip? (not set tool tip)
Replies: 11
Views: 716

Cleanly show/hide tool-tip? (not set tool tip)

I need to show a tooltip, I guess without a wxWindow, because my hover region isn't a wxWindow. I think SetToolTip associates text that wxWidgets picks up on and shows with lower level code that maybe is what I want. This almost works but is a hack and UnsetToolTip just calls DoSetToolTip that delet...