Page 1 of 1

stuck with error

Posted: Sat Aug 08, 2020 3:42 pm
by lupusc
Hi all,
I tried to compile a tool from sourceforge which requires wxwidgets (https://sourceforge.net/projects/netlistviewer/). I got it to compile without error but after invoking the Gui doesn't appear but this error message pops in the console:
(NetlistViewer:5645): Gtk-CRITICAL **: 14:51:15.391: IA__gtk_window_resize: assertion 'width > 0' failed
Failing to get to the root with gdb I tried to make the Hello World example from https://docs.wxwidgets.org/3.0/overview_helloworld.html
It compiles with not error but on invoking the same error occurs.
Finally I downloaded wxWidgets 3.0.5 for a fresh start and tried the procedure from https://docs.wxwidgets.org/trunk/plat_gtk_install.html. But even executing "../configure --with-gtk" fails, telling me that neither GTK+-3.0 nor GTK+-2.0 nor GTK+-1.2.3 is present. This is strange because the system is working properly with the GNOME Desktop (UBUNTU 20.04).
Could anybody help to analyze the problem. Thanks in advance.

Re: stuck with error

Posted: Sat Aug 08, 2020 4:54 pm
by catalin
lupusc wrote:
Sat Aug 08, 2020 3:42 pm
"../configure --with-gtk" fails, telling me that neither GTK+-3.0 nor GTK+-2.0 nor GTK+-1.2.3 is present. This is strange because the system is working properly with the GNOME Desktop (UBUNTU 20.04)
You need the development packages for the GTK version of your choice (i.e. libgtk-3-dev).

Re: stuck with error

Posted: Sat Aug 08, 2020 6:15 pm
by lupusc
Thanks for your effort. That did the trick.