Migrating from wxWidgets 3.1.3 to 3.1.4 - error: decltype cannot resolve address of overloaded function

Do you have a question about makefiles, a compiler or IDE you are using and need to know how to set it up for wxWidgets or why it doesn't compile but other IDE's do ? Post your questions here.
Post Reply
HackiWimmer
In need of some credit
In need of some credit
Posts: 2
Joined: Tue Oct 03, 2017 1:52 pm

Migrating from wxWidgets 3.1.3 to 3.1.4 - error: decltype cannot resolve address of overloaded function

Post by HackiWimmer » Fri Mar 19, 2021 2:55 pm

Hi,
I'm using mingw (g++ 9.2.0) under windows 10. I've downloaded and built wxWidgets 3.1.4 without any issues.

I've an existing project which compiles under 3.1.3 without any error. If I switch to 3.1.4. with a otherwise 100% identical setup I'll tget the following:

Code: Select all

C:/msys64/mingw64/bin/g++.exe  -c  "C:/@Development/@Projekte/c++/CNCGuiController/CncControlerGui/CncAutoProgressDialog.cpp" -Wno-deprecated-declarations -g1 -fpic -O3 -std=c++17 -Wall -mthreads -DHAVE_W32API_H -D__WXMSW__ -DNDEBUG -D_UNICODE -IC:/@Development/wxWidgets-3.1.4/lib/gcc_dll/mswu -IC:/@Development/wxWidgets-3.1.4/include -DWXUSINGDLL -Wno-ctor-dtor-privacy -pipe -fmessage-length=0    -DNDEBUG -DAPP_USE_SPLASH -DBOOST_STACKTRACE_USE_BACKTRACE  -o Release/CncAutoProgressDialog.cpp.o -I. -I. -IC:/@Development/boost_1_71_0 -IC:/msys64/mingw64/include -IC:/@Development/wxsvg-1.5.20/include -IC:/@Development/opencv/build/include -IC:/@Development/openvg
In file included from C:/@Development/wxWidgets-3.1.4/include/wx/window.h:18,
                 from C:/@Development/wxWidgets-3.1.4/include/wx/nonownedwnd.h:14,
                 from C:/@Development/wxWidgets-3.1.4/include/wx/toplevel.h:20,
                 from C:/@Development/wxWidgets-3.1.4/include/wx/dialog.h:14,
                 from C:/@Development/wxWidgets-3.1.4/include/wx/msgdlg.h:18,
                 from ./CncCommon.h:9,
                 from ./3D/GLCncPathData.h:7,
                 from ./3D/GLContextCncPathBase.h:6,
                 from C:/@Development/@Projekte/c++/CNCGuiController/CncControlerGui/3D/GLContextCncPath.h:4,
                 from C:/@Development/@Projekte/c++/CNCGuiController/CncControlerGui/CncMotionMonitor.cpp:5:
C:/@Development/wxWidgets-3.1.4/include/wx/event.h:176:67: error: decltype cannot resolve address of overloaded function
  176 |     static_cast<wxPrivate::RemoveNoexceptEventHandler<decltype(pmf)>::type>(pmf)
      |                                                                   ^
C:/@Development/wxWidgets-3.1.4/include/wx/event.h:91:73: note: in definition of macro 'wxDECLARE_EVENT_TABLE_ENTRY'
   91 |     wxEventTableEntry(type, winid, idLast, wxNewEventTableFunctor(type, fn), obj)
      |                                                                         ^~
C:/@Development/wxWidgets-3.1.4/include/wx/event.h:4419:5: note: in expansion of macro 'wx__DECLARE_EVT2'
 4419 |     wx__DECLARE_EVT2(evt, id, wxID_ANY, fn)
      |     ^~~~~~~~~~~~~~~~
C:/@Development/wxWidgets-3.1.4/include/wx/event.h:4421:5: note: in expansion of macro 'wx__DECLARE_EVT1'
 4421 |     wx__DECLARE_EVT1(evt, wxID_ANY, fn)
      |     ^~~~~~~~~~~~~~~~
....

Any idea?
Many thanks in advance

Stefan

PB
Part Of The Furniture
Part Of The Furniture
Posts: 3063
Joined: Sun Jan 03, 2010 5:45 pm

Re: Migrating from wxWidgets 3.1.3 to 3.1.4 - error: decltype cannot resolve address of overloaded function

Post by PB » Fri Mar 19, 2021 5:38 pm

Is your code still using Connect()? If so, my guess would be a bug fixed by
https://github.com/wxWidgets/wxWidgets/ ... 9bf651d5f8

However, I deduced that only from looking at history of the event.h file so...

Post Reply