wxWidgets-3.1.5: can´t build wxgl

Do you have a question about makefiles, a compiler or IDE you are using and need to know how to set it up for wxWidgets or why it doesn't compile but other IDE's do ? Post your questions here.
stahta01
Super wx Problem Solver
Super wx Problem Solver
Posts: 468
Joined: Fri Nov 03, 2006 2:00 pm

Re: wxWidgets-3.1.5: can´t build wxgl

Post by stahta01 » Thu Jun 03, 2021 2:11 pm

I am surprised you use "--with-regex=sys" I always use "--with-regex=builtin" because "--with-regex=sys" usually failed for me.

But, I do not normally build using the native cygwin compiler like you are almost positively doing to build wxGTK.

To build wxMSW under CygWin it is needed to use the minGW64 cygwin GCC; I build that every year or so to see that it still builds.

Tim S.

BlackMage
In need of some credit
In need of some credit
Posts: 6
Joined: Sun May 30, 2021 10:40 pm

Re: wxWidgets-3.1.5: can´t build wxgl

Post by BlackMage » Sat Jun 05, 2021 12:13 am

is boost regex 1.66 not supported?

stahta01
Super wx Problem Solver
Super wx Problem Solver
Posts: 468
Joined: Fri Nov 03, 2006 2:00 pm

Re: wxWidgets-3.1.5: can´t build wxgl

Post by stahta01 » Sat Jun 05, 2021 2:09 am

BlackMage wrote:
Sat Jun 05, 2021 12:13 am
is boost regex 1.66 not supported?
The software I normally build wxWidgets for likes the wx regex and the default regex does not work with unicode wxMSW.
I have never tried "boost regex" to see if wxWidgets can use it.

Tim S.

ONEEYEMAN
Part Of The Furniture
Part Of The Furniture
Posts: 5226
Joined: Sat Apr 16, 2005 7:22 am
Location: USA, Ukraine

Re: wxWidgets-3.1.5: can´t build wxgl

Post by ONEEYEMAN » Sat Jun 05, 2021 2:20 am

Hi,
It should be.
Try it.

Thank you.

Post Reply